How to install and uninstall Alfresco scanner and importer

Overview

We deliver our migration-center Alfresco adapter (scanner and importer) as an Alfresco Module Package (AMP). This means that you have to install it separately directly on your Alfresco Repository server(s).

Pre-installation tasks

(1) Check the following requirements of our Alfresco adapter:

  • Alfresco version (on Windows or Linux): 3.4, 4.0, 4.1, 4.2, 5.0.2, 5.1, and 5.2
  • Java 1.7 is used by the Alfresco server

(2) Backup your original alfresco.war and share.war files to ensure that you can uninstall the Alfresco adapter if needed.

(3) Ensure that

  • the network connections shown in the diagram below are possible in your environment (the diagram shows the default network ports - these may be different in your environment)
  • the Alfresco server has access to a file share to import / export the content files

Install Alfresco adapter

(1) Stop the Alfresco server.

(2) Copy the mc-alfresco-adaptor-3.3.amp file into the "amps-folder" of your Alfresco installation.

(3) Install the mc-alfresco-adaptor-3.3.amp file as it is described by the wiki guide of Alfresco under https://docs.alfresco.com/5.1/concepts/dev-extensions-modules-management-tool.html 

(4) Start the Alfresco server.

Post-installation tasks

Before you can use the Alfresco adapter, you need to add it as a job server in the migration-center client using the Alfresco server's hostname and the default port 9701. Please see chapter "6.2. Jobservers" in the migration-center Client User Guide for detailed instructions on how to add a job server.

Uninstall Alfresco adapter

(1) Stop the Alfresco server.

(2) Restore the original alfresco.war and share.war files, which you have backed up during the Alfresco adapter installation.

(3) Remove the file mc-alfresco-adaptor-3.3.amp from the "amps-folder".

(4) Start the Alfresco server.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk